مرجع تخصصی برنامه نویسان

بزرگترین انجمن برنامه نویسان فارسی زبان

خطای پایگاه داده در زامارین

ﺳﻪ شنبه, 30 بهمن 1397 11:06

خطای پایگاه داده در زامارین

سلام

من موقع اضافه کردن کتابخانه SQLite.Net.Platform.XamarinAndroidN از NUGet به خطایی بر خورد می کنم .

هر چی هم تو نت گشتم و گوگل کردم ارورر رو پیدا نکردم

لطفا اگه می تونید راهنمایی کنید

متن ارورر:

Severity    Code    Description    Project    File    Line    Suppression State
Error    NU1202    Package SQLite.Net.Platform.XamarinAndroidN 3.1.1 is not compatible with monoandroid81 (MonoAndroid,Version=v8.1). Package SQLite.Net.Platform.XamarinAndroidN 3.1.1 supports: net (.NETFramework,Version=v0.0)    MyFirends    E:\Xamarin Example\MyFirends\MyFirends\MyFirends\MyFirends.csproj    1    


ﺳﻪ شنبه, 30 بهمن 1397 12:50

سلام

این ارور بخاطر وجود تداخل ورژن میان کتابخانه ی monoAndroid81 و کتابخانه ی در حال نصب است .

اگر آپدیتی برای monoandroid آمده آنرا نصب کنید و دوباره امتحان کنید .

یا از ورژن متناسب با ورژن فعلی monoAndroid81 استفاده کنید

کسانی که از این پست تشکر کرده اند : mahdimc,
ﺳﻪ شنبه, 30 بهمن 1397 13:23

میشه بگین چطوری update کنم؟

ارسال پاسخ برای این تاپیک

ارسال پاسخ مخصوص اعضا سایت می باشد ! میتوانید با حساب کاربری خود وارد سایت شده یا ثبت نام کنید