مرجع تخصصی برنامه نویسان

بزرگترین انجمن برنامه نویسان فارسی زبان

خطا در زمان نصب Microsoft.EntityFrameworkCore.Tools.DotNet

پنج شنبه, 27 دی 1397 19:18

خطا در زمان نصب Microsoft.EntityFrameworkCore.Tools.DotNet

سلام، وقت شما بخیر. 
بنده دو پکیج از سه پکیجی که در آموزش گفته میشود را نصب کردم و مشکلی نداشت اما در زمان نصب پکیج Microsoft.EntityFrameworkCore.Tools.DotNet با خطا مواجه میشوم که متن خطا به صورت زیر هست ، ممنون میشم راهنمایی بفرمایید که چه کاری باید انجام بدهم. نسخه dot net core  هم 2.2.102 می باشد.

متن خطا

Severity Code Description Project File Line Suppression State
Error Package 'Microsoft.EntityFrameworkCore.Tools.DotNet 2.0.3' has a package type 'DotnetCliTool' that is not supported by project 'MyCms.DataLayer'.

          

جمعه, 28 دی 1397 15:18

محتوای فایل csproj پروژه ای که میخواهید در آن بسته نصب کنید را قرار بدید.

جمعه, 28 دی 1397 16:36
<Project Sdk="Microsoft.NET.Sdk">

  <PropertyGroup>
    <TargetFramework>netcoreapp2.2</TargetFramework>
  </PropertyGroup>

  <ItemGroup>
    <PackageReference Include="Microsoft.EntityFrameworkCore" Version="2.2.1" />
    <PackageReference Include="Microsoft.EntityFrameworkCore.SqlServer" Version="2.2.1" />
  </ItemGroup>

  <ItemGroup>
    <ProjectReference Include="..\MyCms.DomainClasses\MyCms.DomainClasses.csproj" />
  </ItemGroup>

</Project>

شنبه, 29 دی 1397 09:00

در نسخه جدید نیاز به این بسته نیست 

نمیخواد نصب کنید 

شنبه, 29 دی 1397 09:38

استاد سپاسگزارم

علت اینکه نیازی به نصب نیست بدلیل نسخه 2.2.102  میباشد؟ اگر نسخه 2.1  بود می بایست نصب شود؟!!

شنبه, 29 دی 1397 09:47

ارسال پاسخ برای این تاپیک

ارسال پاسخ مخصوص اعضا سایت می باشد ! میتوانید با حساب کاربری خود وارد سایت شده یا ثبت نام کنید